Introduction
Check engine light appears on your car's dashboard, and looks something like this:
A healthy vehicle is not expected to show this light. If this has appeared during/after your installation of NexCruise,
Observations
Turn ON the car and see the engine RPM.
Is it above 1000RPM?
Yes? It is still not getting the needed A-pedal signal. See first fix in list below.
No? This is good news. Proceed to check the next point.
follow these steps to fix it.
1. A-pedal cable was disconnected when the car was on
Diagnosis:
When you press the A-pedal, is the car responding to that?
Yes? Is the RPM also below 1000? Things are okay, the engine light has come due to an earlier event (most likely you disconnected the A-pedal when the car was ON, read below for more information) but the reason is already rectified. The engine light will also disappear after a few start-stops of the car. You can continue driving the car, things are ok now, and the engine light will fix itself shortly.
No? It is still not getting the needed A-pedal signal. See first fix in Rectifications list below.
Solution
Sometimes, we dont wait long enough for VCU to switch off internally before touching the A-pedal connection. This triggers the A-pedal flag. However if everything else is correct, although the errors will be logged, but its is harmless and check engine light will disappear in a short duration.
A failsafe but lengthy idea is, to always make sure the car is totally turned off before installing or removing the NexCruise. That will make sure you never trigger this particular reason.
2. VCU cable issue
Diagnosis
The VCU expects a certain signal on the Accelerator pedal input. Normally it is given directly by the sensor within the A-pedal. But during installation of NexCruise, when we disconnect the A-pedal, if the signal is missing for any reason, the VCU logs it as an error and the car shows the "Check Engine" light.
These are the flags that are normally raised : A-pedal undervoltage on pin 1, A-pedal undervoltage on pin 2.
solution
The VCU cable isn't securely connected
Did it "click" in place?
Verify it again. And connect the NexCruise bypass connector and see that the physical connectors are connected perfectly. It should respond properly with the bypass connector.
Refer here to see how to connect the bypass connector.
Once it works with the bypass connector, connect NexCruise again and see if this solved the problem.
3. software issue
Diagnosis:
The firmware in your NexCruise is of a different car
You can verify this from the NexCruise app. Go to Menu > About and see the car for which the NexCruise is configured. It must match the car in which it is installed.
solution :
Call our customer support if there is a mismatch.
4. OBD cable issue
Diagnosis:
Check weather the 12v light is turning on in the Unit when connecting to the OBD cable
Solution:
If light is not turning on then reconnect the OBD cable properly and check if the 12v light in unit is turning on, if not replace the OBD cable
5. Unit faulty
Diagnosis
After going through all the above the Unit is not turning on or the engine light is not turning off, we come to conclusion that the unit is faulty.
Solution
Replace the Unit in this case.