Mobile app related

Mobile app related

Sometimes, when we press "connect" on NC mobile app, it keeps trying to connect by cannot connect. 

Possible reasons

Bluetooth of mobile is not ON

Diagnosis

When we click connect on NC app, it shows the error screen:


Solution

1) Close the NC app
2) Turn on BT of mobile
3) Launch the app and tap connect

Signal strength of NexCruise signal is very low

Diagnosis

1) Install BLE Scanner app (this is a third party app)


2) Launch BLE scanner and ensure that you see NexCruise in the BT devices list.
3) Ensure that the signal strength of NexCruise is 50dBm or lower. (Here, a larger number means low signal strength and a lower number means better signal strength)

Solution

If the signal strength is low, move the mobile near the NexCruise device till you see a strong signal. After that, without moving the mobile, close the BLE scanner app, and lauch NC app and connect.

Access permissions are not granted to the app on first run

Diagnosis

If the app permissions are not allowed on the first run the app is unable to connect to bluetooth. 

Solutions

Method 1: 
Uninstall and reinstall mobile app, and this time grant it all the permissions that it needs.

Method 2: 
Go to settings > Apps > Permissions in android, and grant all permissions to NC app.

NexCruise bluetooth interface error

Diagnosis

Despite doing everything above, the app still cannot connect after many retries.

Solution

1) Turn off the car. Let NC turn off.
2) Close the app, and relaunch it.
3) Turn on the car in ACC mode, NC lights should come on.
4) Immediately after NC lights glow, tap connect on app.

Mobile app error

Diagnosis

Despite doing everything above, the app still cannot connect after many retries.

Solution

Restart the phone, reopen the app and connect again.
If this doesn't work, uninstall and reinstall the app and try again.


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