If it isn't working and you've just installed your NexCruise
Diagnosis
When the Battery is not placed in Dial.
Solution
Normally, the NexCruise ships without the battery. Just insert the included battery inside the dial, and you should be good to go!
When you install the battery, it should look like this:
- While inserting the battery, ensure that it goes under the copper hook as shown in the pic above.
- The '+' of the battery must be facing us. Take care not to insert the battery upside-down.
Diagnosis
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Solution
Performing dial teaching is recommended, to ensure that the communication between dial and NexCruise main unit is happening perfectly fine
If you are able to do dial teaching successfully, that means the buttons are properly working with NexCruise.
Case 3: Its still working sporadically even after dial teaching
Diagnosis
Check if the battery isn't gotten weak by the following method:
When you press and hold any button on the dial, you will see a red light emitting from the gap between Blue and Magenta buttons.
It should be glowing solid for as long as you press the button. And should turn off when button is released.
Solution
If it doesn't glow, or if it flickers, the battery needs to be replaced.
Case 4: If its still working sporadically after changing the battery
Diagnosis
Sometimes, fixing the location of NexCruise does the trick.
The NexCruise main unit shouldn't be too close to any metal object. That interferes with the signal of the dial and and causes it to work improperly.
Solution
In Nexon EV, there is a metal box under the steering column. (note the one with red and white wires in the pic below) Ensure that there is atleast one inch gap between your NexCruise unit and this box. You can use some packing foam to make the gap if needed.
With the above remedies, your dial should start working in all probability. If not, please call us and we will help.
If in case your dial was working fine and suddenly stopped working altogether, just call us up as well, and we will help.
Diagnosis
If your unit was shipped between 10th and 24th July 2022, chances are, your dial stopped working because your hardware is from the "2.0" production batch. Our team will get your dial working again, just give us a call and ask to check.
Solution
Connect to our Tech support team and we will install the relevant software version.
Our Tech support phone number is: +91-6367394463
Our sales and general enquiry number is: +91-8003944400