Case one: If cruise was working earlier
In this case when the cruise was working earlier and now its not working then check the following reasons in a sequential order.
Cruise is not working
Diagnosis
Check is the green LED glowing ( even for sometime ) when you press NexCruise.
Solution
Dial Battery Discharged
Diagnosis
Is it already one year or more since you last changed your dial batteries? Or do you do a lot of dial driving?
In darkness, check if the blue backlight glowing in the dial?
If it is not glowing, this may be our reason.
Solution
Replace the batteries in the Dial with fresh 2 nos. AAA batteries. Make sure to not mix batteries brands or age.
Dial problem
Diagnosis
If the Dial doesn't glow blue backlight even after replacing batteries then check weather any liquid entered your dial or Is your dial damaged?
solution
Incase of damaged dial Replace it in NexCruise.
Tuning problem
Diagnosis
Check if the actual speed is lesser than 10kmph as compared to set speed in cruise control then it means the tuning is not correct and cruise is cancelled.
Solution
In case of incorrect tuning contact Aha support team to get your unit tuned. If the tuning is correct then check the further reasons for this issue.
Receiver Faulty
diagnosis
if the dial is working properly then Check RED LED inside the receiver module is working or not.
Before Dial key press
After Dial key is pressed
Solution
If Red LED doesn't glow after pressing Dial button then it mean the receiver can be faulty, in this case replace the receiver. If its working properly then check the next issue.
Dial key connectivity with NexCruise app
Diagnosis
Ensure that dial key is received by NexCruise app.
- Open logs in NexCruise app.
- Press Dial Key
Ensure that you receive log as soon as you press the key
Solution
If the log is received in NexCruise app than it means Dial is connected to the app. If not then connect to the app manually.
Brake sensor not mounted properly
Diagnosis
If the brake sensor dislocates from its position, as a safety mechanism, Cruise doesn't engage. Ensure that the brake sensor is mounted correctly. To ensure check weather the brake sensor is touching the metal of brake pedal or not.
Not Mounted properly
We can also check this in the NexCruise app, The coast light doesn't come when the brake pedal is pressed
Solution
Mount the Brake sensor properly in a way that its connecting to the metal of the Brake Pedal.
Mounted Correctly
Check weather the coast light is coming when we press the brake pedal in NexCruise app.
If the coast Light is coming when the brake pedal is pressed then it means the Brake sensor is working properly.
Dial Teaching Needed
Diagnosis
If the above diagnosis doesn't solve the issue regarding signal not received from dial when pressed we do Dial teaching.
Solution
Unit Faulty
Diagnosis
If the above diagnosis doesn't resolve the issue then we may come to the conclusion that the NexCruise unit may be faulty.
Solution
In this case we replace the Unit and check that cruise is working when button is pressed on the dial.
Case two: If its not working from the start
Possible reasons:
Bake sensor not mounted and its needed by software
Speed not successfully read by NexCruise.
New car not yet supported
Resolution: For all the above cases, Directly connect to our Tech-support team over a call.